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8. Select JPEG – Better Quality from the Saved Settings drop-down menu; click Export. 

 

9. Navigate to your “blogreader/assets” folder. You might consider giving the file a new name, or saving it in 
a new folder, or moving your original images to another folder—if you save this edited version over the 
original, you lose the original. Click Save. 

10. Do the same with “dreamcatcher.jpg”. 

Re-Insert the Images In Dreamweaver 
1. In Dreamweaver’s Design view, select the image you’re replacing and delete it. 

2. With the cursor still in the table cell, follow the steps to insert an image, this time choosing the resized 
version. 

3. Save the file. 

The Frameset Page 
Frames make it possible for a single browser window to display multiple web pages at the same time. The blog 
reader we’re building is actually a web page with three frames—one frame displays the navigation page, one 
frame displays the description page, and one frame displays the actual blog. In addition to those three content 
pages (navigation, description, blog), we need a fourth file that defines the frames. This frameset file tells the 
browser how many frames to display, the dimensions of each, whether or not to show a border, whether or not to 
include scrollbars, and where to find the content (internal or external web page) for each frame. 

The frameset page is the controlling page here—it’s the page that you’ll load in the browser when you’re finally 
done. 
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Creating a Frameset 
1. In Dreamweaver, create a frameset by doing one of the following: 

• If the splash screen is visible, go to Create from Samples > Framesets. 

 

• Go to File > New [or Ctrl + N]; in the dialog box that opens, select Framesets and Fixed Left, Nested Top. 
Click the Create button. 

 

2. Save the file: go to File > Save As… [or Ctrl + S]. 

3. Navigate to your H: drive “ENGL323/blogreader” folder. 

4. Name your file “blogreader.htm” and click the Save button. 

Putting Your Pages Into the Frames 
You’ve built two pages so far: “blogmenu.htm” goes in the left frame, and 
“blogdescriptions.htm” goes in the top frame. To put them there, you’ll need to use the 
Frames panel. 

On the far right of your screen you have a column of control panels. Mine currently looks 
like the image to the right; yours will look similar. In my image, the Frames panel and 
the Files panel are currently open, while the others are closed. 

1. Open your frames panel by going to Window > Frames [or Shift + F2]. 

2. Select the left frame by clicking in the left frame in the Frames panel. 

3. In the Properties panel, define the source document for the left frame by clicking 
the folder icon and navigating to your “ENGL323/blogreader” folder. Select the 
“blogmenu.htm” file. 
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4. Click Ok. If you’re prompted to save files, click Ok. 

5. Take a moment to look over the Properties panel and see your other options. 

6. In the Frames panel, select the top frame. 

7. In the Properties panel, define “blogdescriptions.htm” as the source file for the top frame. 

8. In the Frames panel, select the main frame. 

9. In the Properties panel, define the source by typing http://rightbrain-kristy.blogspot.com 
and hitting Enter. 

10. Save your work. Remember that you’re working with three files now—the menu, the descriptions, and the 
frameset. Going to File > Save All is a quick way to save all of the files at one time. 

Resize Your Frames 
You can see easily enough that the menu text is cramped in its frame. Resize by grabbing the border in the Design 
window and dragging it until you’re happy with the width. Or you can be more precise: 

1. In the Design view, click on the vertical border that separates the left frame from the two right frames. 

 

2. In the Properties panel, enter 130 in the Column Value field and hit Enter. 

 

3. When you click on a frame border in the Design window, the Properties panel gives you access to frameset 
properties. Review your options: you can set the column sizes (notice to the right of the panel that the 
columns are represented—you can click here to choose one column or the other), you can set borders to be 
visible, and then set their width and color. 

• Clicking inside a frame in the Design window brings the file in that frame into focus, and the 
Properties panel changes to reflect document and text formatting options. 

• Clicking inside a frame on the Frames panel changes the Properties panel yet again, giving you access 
to controls for the frame’s source, coloring, and so forth. 
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4. Resize the top frame. Recall that you set the second, fourth, and sixth rows to be 125 pixels high, so you’ll 
need at least that much room in the top frame. The point is for only one description to be visible at a time. 
The description rows are all 125 pixels high; we didn’t set the header rows. I find that 140 pixels 
successfully grabs the header and the descriptive row. Set it. 

5. Save all. 

Redirect Your Links 
The links in your menu have to be told to point to the main frame in your frameset—right now they point to a new 
window or tab. 

1. Put the cursor in one of the links. 

2. In the Properties panel, choose mainFrame from the Target drop-down menu. 

3. Repeat for the other two links. 

4. Recall when you worked with targets before that your options did not include mainFrame, topFrame, or 
leftFrame. You have those options now because Dreamweaver recognizes that you’re working in a 
frameset, and frames have to be able to target each other. Dreamweaver automatically assigned the names 
(mainFrame, topFrame, and leftFrame). You can rename them if you want, but that will complicate things 
more than I want to mess with, so: do it on your own time. 

5. Save all. 

Preview 
You’re ready to preview your work. If everything is saved, click on the preview icon: 

 

If it’s all working, you should see the menu, the descriptions, and Kristy’s blog. Clicking the links should open the 
other blogs in that frame. 

One design problem I see is that the picture of the flowers is cut off by the blog frame. You could go back to the 
file and make the top frame slightly taller, but a different solution is going to present itself shortly, so sit tight. 

Another problem is that the blogs change when you click each link, but you still see only Kristy’s description. 
Again, sit tight. 

Updating Pages in Their Frames 
When you built the menu and the descriptions, you had each file open in different windows. While you’re 
working on a frameset, you have the files open in a single, framed window, and you can make changes to those 
files right there. 

6. In the menu frame, place the cursor after the word “Posters” and hit Enter. 

7. Type Cookology 101 and hit Enter. 

8. Select “Cookology 101” and set the link to http://jennawak.blogspot.com. 
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9. Set the Target to mainFrame. 

Updating the Description Page 
Adding the description for Jenna’s page is tricky because the frame is short and doesn’t scroll, so it’s difficult to 
work in. 

1. Turn scrolling on: click on the top frame in the Frames panel, and in the Properties panel select Yes from 
the Scroll drop-down menu. 

2. Scroll to the bottom of the frame and put your cursor in the bottom row of the table. 

 

3. Go to Insert > Table Objects > Insert Row Below. Repeat. 

4. Select the two cells in what is now Row 7 and merge them: Modify > Table > Merge Cells [or Ctrl + Alt + M]. 

5. Type Cookology 101 – Jenna Walsh, set the background color to match your other header rows 
and set the text color to match your other header text. 

6. Grab the border between rows seven and eight, and make the header row less tall until it more or less 
matches your other header rows. 

7. In Row 8, Column 2, type I think this is a great chance to spend sometime with 
my grandma and obviously get to know her secret recipes! Maybe I will 

even be able to teach my mom something in the meantime! 

8. Save all. 

Working With Images Again 
Dreamweaver can send images you’ve manipulated directly to Fireworks for exporting. 

1. Open a browser and go to Jenna’s blog: http://jennakwak.blogspot.com. 

2. Right-click the cartoon image and save it to your H: drive. 

3. In Dreamweaver, put your cursor in Row 8, Column 1. 

4. Go to Insert > Image and navigate to the picture you just saved. Click Ok. 

5. Resize the image to a width of 110 pixels. 

6. In the Properties panel, click the “Optimize with Fireworks” icon. 
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7. Fireworks will open and ask you if you want to use another file as your source or if you want to alter and 
save the original image. Click Use This File. 

8. In the window that opens, click the Update button. 

9. Save all. 

Previously, you’d opened the original image in Fireworks and altered it and saved it. Here, you’ve changed the 
image’s size in Dreamweaver, sent your updated version to Fireworks, and Fireworks saved it, overwriting the 
original. It’s a little bit easier, but it also means your original image is gone. 

Internal Links 
Links can go to another web page or another site, or they can be used to jump to a part of a web page. Internal 
links allow you to navigate within a single page: you can put a table of contents at the top of a page with links that 
jump to different sections of the page (and with links that jump back to the table of contents); you can also jump 
to the internal links of an entirely different page. 

By putting anchors by each of the blog names in our description page, we create internal links. Then, by changing 
our menu links to point to those anchors, we can make the description page jump around to show the description 
for each blog. 

Creating Anchors for Internal Links 
1. Place the cursor before “the right brain” in the description page. 

2. Go to Insert > Named Anchor [or Ctrl + Alt + A]. 

3. A dialog box opens asking for a name—type kristy and click Ok. 
You’ll see an anchor symbol appear in the design window: 

 

4. Put anchors before each of the other blog names: 

• for Politicoscope, enter the name rick 

• for Take Down Your Posters, enter the name saraT 

• for Cookology 101, enter the name jenna 

5. Save all. 

Linking to Anchors 
1. Put the cursor anywhere in the link to “the right brain” on the menu page. 

2. Change the link from Kristy’s blog to blogdescriptions.htm#kristy 

3. Change the target from mainFrame to topFrame 

4. Repeat for the other links, changing from URLs to: 
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• blogdescriptions.htm#rick 

• blogdescriptions.htm#saraT 

• blogdescriptions.htm#jenna 

5. Change the target for each from mainFrame to topFrame. 

6. Save all, and preview in Explorer. 

You should now see each description appear as you click the links. Notice how each description appears at the 
very top of the browser window—there’s no space. Remember how when the page first loads there’s space above 
Kristy’s description and the bottom of the flower image is cut off? Well, we have a clue of how to fix that now, 
don’t we? 

Introducing Javascript 
Unfortunately, as I’m sure you noticed, our links no longer open the blogs. Links in HTML can do only one thing 
at a time, but we want the links to open a blog in one frame AND jump around the description page in another 
frame. The solution is Javascript. 

Javascript is a low-level programming language. When you write Javascript, you are writing little programs that 
browsers execute. What’s nice and easy is the fact that you can embed Javascript in your HTML; what’s difficult 
is that you have to know how to write it in the first place.  

1. The first thing we need to do is change our links back. Re-enter the URLs for each link in the menu, and set 
the target for each back to mainFrame: 

• the right brain: http://rightbrain-kristy.blogspot.com 

• Politicoscope: http://politicoscope.blogspot.com 

• Take Down Your Posters: http://takedownyourposters.blogspot.com 

• Cookology 101: http://jennakwak.blogspot.com 

2. Now click the Split button to see both the Design and Code windows. Resize the windows so that you can 
see all of the links in the menu. 

 

3. In the menu, put the cursor anywhere in the link for Kristy’s blog. A cursor will appear in the Code window 
as well, in the code for the link. 
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4. Read the code; get familiar with it. The code for Kristy’s link should make a little sense to you—you can 
see the URL (in blue), you can see that the target is set to “mainFrame”; you can see the text for the actual 
link that appears in the browser window. Put the cursor after “mainFrame” and before the >: 
target=“mainFrame”|> 

5. Type a space and then 
onclick=“top.topFrame.location.href=‘blogdescriptions.htm#kristy’” 

6. The entire code should now look like this (don’t hit return at any point—let the code wrap on its own): 
<a href=“http://rightbrain-kristy.blogspot.com” target=“mainFrame” 

onclick=“top.topFrame.location.href=‘blogdescriptions.htm#kristy’” 

7. Repeat for the other links: 

• Politicoscope: 
onclick=“top.topFrame.location.href=‘blogdescriptions.htm#rick’” 

• Take Down Your Posters: 

onclick=“top.topFrame.location.href=‘blogdescriptions.htm#saraT’” 

• Cookology 101: 

onclick=“top.topFrame.location.href=‘blogdescriptions.htm#jenna’” 

8. Save all and preview in Explorer. 

Adjusting the Initial Appearance of Kristy’s Description 
Finally, let’s get rid of that space above Kristy’s description when we first load the page. 

1. With the Split view still in effect, click anywhere in the description page. 

2. Scroll through the code until you see <body>; for me it’s in line 14. 

3. Put the cursor before > and type a space, then: 
onload=“location.href=’blogdescriptions.htm#kristy’” 

Oh, and let’s turn off the scroll bars in the description page: 

4. In the Frames panel, select the top frame. 

5. In the Properties panel, select No from the Scroll drop-down menu. 

The Javascript you entered in step 3 tells the page to jump to the anchor for Kristy’s description after the page 
loads (onload), removing the white space at the top that the browser automatically puts in. 

 

You’re done. 


