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Building a Blog Reader 
The page you’re going to build in this exercise is not likely something you’ll use long-term, but it will show you 
how to do a lot of useful things in Dreamweaver. You’ll work through the following tasks: 

• Build a simple page with external links. 
• Build a simple page using a table for layout. 
• Manipulate and insert images into a page. 
• Build a frameset to hold your pages in a single browser window. 
• Experiment with javascript to make a link affect two different windows, which is pretty cool if you 

think about it. 

Blog Reader Components 
The reader you’re building here consists of three web pages: 

1. A navigation page that lists links to our class blogs. 
2. A description page that provides a brief overview of each blog. 
3. A frameset page that will display the navigation and description pages, along with the class blogs. 

The Navigation Page 
The navigation page includes a header and links to our class blogs. As such, it’s pretty simple to build. 

Create and Save the Navigation Page 
1. In Dreamweaver, open a new file by doing one of the following: 

• If the splash screen is visible, go to Create New > HTML. 

 
• Go to File > New [or Ctrl + N]; in the dialog box that opens, select Basic page and HTML. Click the Create 

button. 

 
2. Save the file: go to File > Save As… [or Ctrl + S]. 
3. Navigate to your H: drive “ENGL323” folder. 
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4. Create a new folder by clicking on the New Folder icon. 

 
5. The new folder will appear with the name “New Folder” selected and ready to be changed. Name it 

“blogreader” then double-click the folder to open it. 
6. Name your file “blogmenu.htm” and click the Save button. 

Create Links in Your Navigation Page 
1. In the Design window, type Blogs and hit Enter. 
2. Type the right brain and hit Enter. 
3. Type Politicoscope and hit Enter. 
4. Type Take Down Your Posters and hit Enter. 
5. Select the word Blogs. 

 
6. In the Properties panel, choose Heading 1 from the Format drop-down menu. 
7. Select the right brain. 

 
8. In the Properties panel, type http://rightbrain-kristy.blogspot.com in the Link field and hit 

Enter. 
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9. Create links for the other two blogs: 
• Politicoscope: http://politicoscope.blogspot.com 
• Take Down Your Posters: http://takedownyourposters.blogspot.com 

10. Save the file. 
You have a web page now that links to three of our class blogs. Links are basically easy to create, although there 
are additional things we can do to them. 

Open Links in a New Window 
Your links will open inside the current window, replacing your page with the linked page. You can make the 
pages open in a new window (or a new tab in a browser that supports tabs): 

1. Put your cursor anywhere in the text for one of your links. You should see the URL in the Link field of the 
Properties panel. 

2. Underneath the Link field is a Target drop-down menu. Choose _blank from this menu. 

 
3. Do this for each link. 
4. Save the file. 

The other options in the Target drop-down menu relate to frames. You probably won’t use them much, but FYI: 
• _parent replaces a frameset inside a frameset, and opens the new page where the inside frameset had 

been.  
• _self opens the new page inside the frame the link is in. 
• _top replaces all of the frames with the linked page. 

The Description Page 
This page will provide a brief overview of the blogs you’re linking to. The description will appear in one frame, 
with the blog appearing in another. Putting this page together will introduce you to working with tables and 
images in Dreamweaver. 

Create and Save the Description Page 
Open a new file in Dreamweaver and save it: name the file blogdescriptions.htm and save it to your 
“ENGL323/blogreader” folder. 

Build the Initial Table 
You can always change the design of your tables after you create them, but it pays to do some planning and figure 
out how many rows and columns you’ll need. We’ll need six rows and two columns. 

1. Go to Insert > Table [or Ctrl + Alt + T]. 
2. Set the following parameters: 

• Rows: 6 
• Columns: 2 
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• Table width: 95 percent 
You can set a table’s width as a percentage or as a number of pixels. Using a percentage means the 
table will resize itself according to the width of the browser window—in this case, no matter how wide 
the browser window, the table will be 95% as wide as the window. If you set pixels, the table will stay 
the same width no matter the size of the window. 

• Border thickness: 0 pixels 
Setting the border to 0 makes it invisible. Most of the time when you use a table for layout you’ll hide 
the borders. 

• Cellpadding: 5 pixels 
This sets the amount of space between a cell’s border and its contents. 

• Cellspacing: 0 pixels 
This sets the amount of space between cells. 

3. Click Ok. You should see something like the image below. When the table is selected, you can drag the 
resizing handles (the small black boxes) to change the height (bottom box), width (right box), or height and 
width (corner box). 

 
You’ll also notice the Properties panel at the bottom, where you can re-define the table properties you set 
when you first inserted the table. 
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4. Click on the small green arrow under the left column (you can also select a column by moving the cursor 
over the top border of the table—watch for the down arrow to appear). A context menu will appear; select 
Select Column. 

 
5. Notice that the Properties panel has changed. Set the width of the column to 110 pixels, and the vertical 

alignment (Vert) to Top. 
6. Select the left column and set its vertical alignment to Top. 
7. Select the top row: click in one cell and drag across the other cell to select both, or move the cursor over the 

table’s left border until an arrow appears and then click. 
8. Go to Modify > Table > Merge Cells [or Ctrl + Alt + M] to combine the cells into one. 
9. In the Properties panel, set the background color to a dark grey or black by clicking on the small black 

arrow in the Bg box (refer to the image above). A palette of color swatches will open for you to choose 
from. 

10. In the Properties panel, set the text color for the row to white. Refer to the image above. 
11. Merge the cells in rows three and five and set their background color and text color. Your table should look 

like this: 
 

  
  
  
  
  
  

Inserting the Descriptions 
1. In the top row, type the right brain – Kristy Cerullo. 
2. Select the text and choose Heading 3 from the Format drop-down menu in the Properties panel. 
3. In the third row, type Politicoscope – Rick Rinaldi; select and format as Heading 3. 
4. In the fifth row, type Take Down Your Posters – Sara Tomedi; select and format as Heading 3. 
5. In Row 2, Column 2, type Kristy’s “the right brain” focuses on organic food, 

offering information about shopping for organic food, cooking with it, 

working it into existing recipes, as well as commentary about related 

issues. 
6. While the cursor’s still in this cell, set the cell’s height at 125 in the Properties panel. 
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7. In Row 4, Column 2, type Rick’s “Politicoscope” is to inform, entertain, and 
engage in some general opining about the current issues in our country. 

8. While the cursor’s still in this cell, set the cell’s height at 125 in the Properties panel. 
9. In Row 6, Column 2, type Sara’s “Take Down Your Posters” is her chance to talk 

about what art is, where it’s going, what it means to her and why you 

should chip off some of the surface paint before you buy the house. 
10. While the cursor’s still in this cell, set the cell’s height at 125 in the Properties panel. 
11. Save the file. Your table should look something like this: 

 

Working With Images 
Dreamweaver is not a graphics program. You can use it to see how images will look on a web page, but that’s 
about it. If you want to create or alter an image, you will need to work with it in a program like Fireworks, 
Photoshop, Paint, Illustrator, and so on. 

Inserting Images in a Web Page 
1. Open your “blogdescriptions.htm” file in Dreamweaver. 
2. Open a browser, and go to Kristy’s blog: http://rightbrain-kristy.blogspot.com 
3. Right-click on the picture of flowers; choose Save Picture As… and navigate to the “blogreader” folder on 

your H: drive. 
4. Create a new folder, name it assets and save the picture in this folder. 
5. In your browser, go to Sara’s blog: http://takedownyourposters.blogspot.com 
6. Save the very large picture (Save Background As…) to your “blogreader/assets” folder. 
7. In Dreamweaver, put the cursor in Row 2, Column 1. 



ENGL 323: Writing for New Media Spring 2008 7 of 16 

Dr. Michael Little michaellittle@kings.edu Hafey-Marian 418 

8. Go to Insert > Image; navigate to your “blogreader/assets” folder and choose “flowers.jpg”—notice that the 
dialog box tells you the dimensions and file size of the image; this image is 200 pixels wide, and the table 
cell you’re putting it in is set at 110 pixels wide. Something’s got to give. 

 
9. Click Ok. 

Notice now that the cell has expanded to accommodate the image. If you look at the bottom of the table, 
you’ll see that the structure information reads 110 (200) for this column. That means the column is set to be 
110 pixels wide, but is forced to actually be 200 pixels wide. 

 
10. Resize the image by grabbing the resizing handle in the lower-right corner of the image. Hold the Shift key 

to keep the height/width ratio the same and drag the handle, making the image smaller. Watch the 
Properties panel—the image size will update as you drag. Get it down to 110 pixels wide. 
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11. If you make a mistake, or lose the original picture’s proportions, click the Reset icon to start over. 

 
12. Insert and resize “dreamcatcher.jpg” in Row 6, Column 1. 
13. Save the file. 

Notes about Resizing Images 
Resizing an image in Dreamweaver does not change the original image; the “dreamcatcher” picture file is still 
64K, and the dimensions are still 600x597. If you put this web page and that image on the web server, browsers 
will load your page, download the full-sized image, and re-size it for presentation. Do not make browsers resize 
an image. Loading an image that’s bigger than it needs to be is slow, and browsers are unreliable at resizing 
images. 

Use Dreamweaver to play with image sizes, but once you find the size you want, edit the original in a graphics 
program, scale it to the size you want, and save it. 

Avoid scaling an image larger than its original dimensions. This will make for a fuzzy, boxy, “pixelated” image. 
Graphics programs have to insert new pixels to fill the larger size, and they do this by duplicating existing pixels. 
This creates boxy images. Making an image smaller than its original size doesn’t have as obvious an effect on 
appearance. 

Using Fireworks to Resize an Image 
1. Open Fireworks. 
2. Go to File > Open and navigate to your “blogreader/assets” folder; select “flowers.jpg” and click Open. 
3. Go to Modify > Canvas > Image Size… 
4. Make sure the Constrain Proportions and Resample Image boxes are checked. 

 
5. Change the pixel width to 110; the height should change automatically to 83. 
6. Click Ok. 
7. Go to File > Export Preview… 
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8. Select JPEG – Better Quality from the Saved Settings drop-down menu; click Export. 

 
9. Navigate to your “blogreader/assets” folder. You might consider giving the file a new name, or saving it in 

a new folder, or moving your original images to another folder—if you save this edited version over the 
original, you lose the original. Click Save. 

10. Do the same with “dreamcatcher.jpg”. 

Re-Insert the Images In Dreamweaver 
1. In Dreamweaver’s Design view, select the image you’re replacing and delete it. 
2. With the cursor still in the table cell, follow the steps to insert an image, this time choosing the resized 

version. 
3. Save the file. 

 


