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Using Color to Establish Visual Hierarchies 
Color is useful in document design to group elements on a page or screen, to create emphasis, to show how 
elements relate to each other, and to even provide visual cues about when a page ends. 

Put a Background Color in the Table 
1. Select both cells in the first row by clicking and dragging or by clicking in each one while holding down 

the Ctrl key. 

2. In the Properties panel, find the Bg color selection box. Click on the black arrow in the lower right corner to 
open the color palette. 

3. Move the eyedropper over the different colors in the palette and notice at the top of the palette that there is 
a six-digit code that changes for each color. Move toward the oranges until the code reads #FF9900. 

 

4. Left-click to select that color as the background for the selected table cells. 

5. Ctrl + click the second row in the table to select that cell. 

6. Select #FFCC66 as the background color for the second row. 

7. Put the cursor anywhere in the last row of the table. 

8. Insert a new row: Insert > Table Objects > Insert Row Below. 

9. Merge the cells in the new row to make one cell: Modify > Table > Merge Cells [or Ctrl + Alt + M]. 

10. Select #FF9900 as the background color for that bottom row. 

11. Save the file. 

Using Color to Establish Hierarchies 
Notice how these two colors relate to each other. The top color is darker and heavier; it’s more dominant. The 
next color is lighter but similar; it’s subordinate. These colors then indicate the relative value of the content 
associated with them. The title is dominant and the heavier color reinforces that dominance; the background info 
is secondary and the lighter color reinforces that subordination. 

The use of similar background colors also ties these two elements together. The title and the background info are 
visually linked and now function as one element on the screen. 

Repeating the top dominant color at the bottom of the page provides a visual bracket, helping to indicate that 
you’re at the bottom and there’s no more content after this point. 

FYI: There’s info about the color codes at the end of this handout if you’re interested. 
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Using Styles to Create Borders 
So far you’ve been applying formatting to text, which makes Dreamweaver create a style that you then rename 
and modify. You can also create styles from scratch. 

1. In the Design panel (or CSS panel if you’re using an older version of Dreamweaver), click the New CSS 

Style icon. 

 

2. In the dialog box that opens, set the following: 

• Name: dotborder 

• Selector Type: class 

• Define in: This document only 

3. Click Ok. 

4. Dreamweaver automatically opens the dialog box you’re familiar with from editing other styles. Select 
Border from the Category menu. 

5. For Style, Width, and Color, de-select Same for all. 

6. Under Style, select dotted from the Top drop-down menu. 

7. Under Width, type 1 in the Top drop-down menu. 

8. Under Color, select #000000 (black) from the Top color palette. 

9. Click Ok. 

10. Ctrl + click in the second row of the table to select that cell. Look in the Properties panel—if the style drop-
down reads background, you’ve selected the text in the cell, not the cell. If the style drop-down reads 
none, you’re good to go. 

11. In the Properties panel, select dotborder from the Styles drop-down menu. 

12. Save the file. 

13. Dreamweaver doesn’t render borders well, so preview the file in Explorer by clicking the preview (globe) 
icon or by choosing File > Preview in browser > [Internet Explorer]; you should see a tiny dotted border 
between the top two rows. 

Designing Custom Borders in Fireworks 
Time to start creating your own graphics. 

1. Open Fireworks (from Windows: Start > All Programs > Macromedia > Macromedia Fireworks) and open a 
new file: File > New [or Ctrl + N]. 
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2. In the New Document dialog box, set: 

• Width: 5 pixels 

• Height: 3 pixels 

• Resolution: 72 pixels 

3. Click Ok. 
The tiny little white rectangle you see in the middle of the screen is your canvas; this is where you will 
draw your image. It’s only 5 pixels by 3 pixels, which is why it’s so small. We don’t need it to be bigger 
than this, but we need to be able to see it better. 

 

4. Zoom in to 1600% by either: 

• Ctrl + 6 

• Ctrl + + over and over and over 

• Select 1600% from the zoom drop-down in the lower right corner of the design window 

5. Turn on a grid to help you draw: View > Grid > Edit Grid… 

• Color: #000000 

• Select Show grid 

• Enter  1 pixel in the horizontal and vertical fields 
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6. Click Ok. You should see a grid of five boxes in three rows on the canvas: 

 

7. On the far left you’ll see a Tools panel. Click the pencil icon roughly in the middle, and select #FF9900 as 
the pencil’s drawing color toward the bottom. 

 

8. On the canvas, and with the Pencil tool selected, click in each box of the grid’s top row. The grid is 
showing you the fifteen pixels in this image, and the pencil makes a one-pixel dot when you click it. You 
should see each box fill with orange. 

9. Click in the middle three boxes of the middle row. 

10. Click in the center box of the bottom row. You should see this: 

 

11. Go to File > Export Preview… [or Shift + Ctrl + X]. 

12. From the Saved settings: drop-down menu, select GIF WebSnap 128. 

13. Click the Export button. 

14. Navigate to your “gridlayout” folder on your H:\ drive. 

15. Create a new folder and name it “assets”; save your image as “borderarrow.gif” in the “assets” folder. 

Creating Your Custom Border 
1. In Dreamweaver, create a new style: 

• Name: borderarrow 

• Selector Type: class 
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• Define in: This document only 

2. Click Ok. 

3. Select Background from the Category menu. 

4. Click the Browse button next to the Background image field. 

5. Navigate to your “gridlayout/assets” folder. 

6. Select the “borderarrow.gif” file and click Ok. 

7. From the Repeat drop-down menu, select repeat-x. 

8. Click Ok. 

You’ve created a style that puts your newly created orange arrow in the background of the cell and repeats it along 
the x-axis (horizontally). You had several options to choose from: 

• No-repeat would display the image one time in the background, in the top left corner. 

• Repeat would repeat the image all the way across and all the way down in the background—this fills 
the background with the image. 

• Repeat-x repeats only on the x-axis (horizontally) and only once—this puts the background image 
at the top of the background and repeats it horizontally all the way across. 

• Repeat-y repeats only on the y-axis (vertically) and only once—this puts the background image on 
the far left and repeats it vertically all the way down. 

9. Ctrl + click the cells in the “Problem” row; in the Properties panel, select the borderarrow style. 

10. Apply the borderarrow style to: 

• Both cells in the “Solution” row 

• Both cells in the “Advantages” row 

• Both cells in the “Guidelines” row 

• The “Sketch Out Grid…” cell 

• The “Create Sample Web Pages…” cell 

• The “Study How Other Web Pages…” cell 

11. Save the file and preview it. You should see something like this: 
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12. Feel free to try all of the other background settings for the style, and preview them to see the different ways 
the background image is displayed. 

Creating the Rollover Image 
A rollover image is an image that changes when you put the cursor over it (or over some relevant text). Many 
buttons on web pages are rollovers—you put the cursor over the button and the button lights up, and when you 
click it the button appears to depress. 

We’re using the idea of rollovers to highlight different areas of the EPA’s website. We’ll use the image caption as 
our rollover text—when you rollover the text about the menu, for instance, the navigation bar on the image will be 
highlighted. 

Rollovers rely on two things: multiple images, and Javascript code to swap the images as you click or put the 
cursor over them. 

Create the EPA Images 
We’ll need five images: 1) the main EPA web page image, 2) highlighting the navigation bar, 3) highlighting the 
“Recent Additions” and “Search,” 4) highlighting the main content in the center, and 5) highlighting the relevant 
content on the right. 

1. Download the main EPA screenshot I’ve created for you from the class web page—save it to your H:\ 
drive’s “gridlayout/assets” folder. 

2. Open the image in Fireworks. 

3. Make sure the Layers panel is open in the upper right. 

 

4. The image currently has two layers—one that contains the picture of the EPA’s website and one for storing 
web information. We’re not going to work with the Web Layer. 

5. Create a new layer that duplicates Layer 1 by doing one of the following: 

• In the Layers panel, click anywhere on Layer 1 and drag it down onto the “New/Duplicate Folder” 
icon. 

• Click on the New / Duplicate Layer icon to create a new, empty layer; click on the main image and copy 
it (Ctrl + C or Edit > Copy); click on Layer 2 in the Layers panel; paste (Ctrl + V or Edit > Paste). 
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6. You won’t see any difference on the canvas, but you have two pictures of the EPA website now; one’s 
directly on top of the other. In the Layers panel you should see this represented as two layers with identical 
content: 

 

7. Click on Layer 2 to select it. 

8. In the Tools panel on the far left, set the fill color to black (#000000) and the stroke color to nothing. 
Select the Rectangle tool: 

 

9. With the Rectangle tool selected, draw a rectangle on the canvas (any size). You should see a black 
rectangle on the canvas, and Layer 2 in the Layers panel should now include the EPA image and the 
rectangle. 

10. The rectangle should be selected (you should see blue boxes on the corners. If not, select the Pointer tool—
the black arrow at the top of the Tools panel—and click on the rectangle). In the Properties panel, set the 
following: 

• W: 475 (sets the width of the rectangle to 475, the width of the canvas) 

• H: 395 (sets the height of the rectangle to 395, the height of the canvas) 

• X: 0 (puts the left edge of the rectangle at the far left of the canvas) 
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• Y: 0 (puts the top edge of the rectangle at the top of the canvas) 

You now have a black rectangle on top of a picture of the website, on top of a picture of the website. 

11. Set the opacity of the rectangle at 50%: at the far right of the Properties panel, enter 50 in the field where 
you see 100 (next to the drop-down menu reading “Normal”). 

 

You’re now looking through the black rectangle and seeing the EPA image below it. 

12. Click on the “Layer 2” text in the Layers panel to select all of the elements of that layer. 

13. In the top right of the Layers panel you’ll see a bulleted list icon—this is a drop-down menu. Click on it to 
open the menu and select Flatten Selection. You’ll see in the layers panel that the rectangle and EPA image 
are now a single element, a darkened version of the original EPA image. 

14. Blur the darkened image: make sure the Pointer tool is selected in the Tools panel, and make sure the 
Bitmap in Layer 2 is selected in the Layers panel. At the far right of the Properties panel (where you set the 
opacity to 50%) you’ll see an Effects drop-down menu. Click on it to open the menu, go to Blur > Gaussian 

blur… and set the slider at 2.0. Click Ok. 

15. At the bottom of the Layers panel you’ll see an icon with a white circle inside a grey box.  Click on this 
to activate a Mask; you’ll see a white box appear next to the image in Layer 2. 

16. Select the Marquee tool in the Tools panel (it looks like a box with a dashed border) and draw a box around 
the navigation part of the EPA image: 

 

17. Select the Paint Bucket tool  (it looks like a tipped paint bucket), move the cursor anywhere inside the 
box you just drew, and click. The box you drew should no be filled with a clear, bright, not blurry image of 
the navigation bar. 

18. Ctrl + D will deselect the box you just made and filled. 
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What Just Happened? 
Here’s what just happened: you told Fireworks to treat the dark layer as a mask. A mask is a way to hide parts of 
an image; you are hiding most of the bright EPA image behind the dark image mask, but you are revealing the 
left-hand navigation menu. Remember that you have a darkened version of the EPA image on top of the original 
version of the EPA image. 

In a mask, black areas are transparent, and white areas are not. Grey areas are semi-transparent, depending on how 
dark or light the grey is. You drew a rectangle and filled it with black, but since it’s a mask you don’t see the 
black. You just see what’s behind it. 

In the Layers panel you see the thumbnail of the dark image and a thumbnail of the mask side-by-side. What you 
see on the canvas is a preview of your mask—if you apply the mask to the dark layer, the dark layer will 
permanently become this mask. But we’re going to create several masks, so we won’t ever lock-in this mask. 

Regardless, you should see this: 

 

Export This Image 
1. File > Export Preview… 

2. In the export dialog box that opens, just click the Export button. 

3. Navigate to your H:\ drive’s “gridlayout/assets” folder, name the file EPAleft, and Save. 

Create the Other Images 
4. Delete the mask by clicking on the mask thumbnail in Layer 2 and dragging it to the trash can in the Layers 

panel. In the dialog box that opens, click Discard. 

5. With the Bitmap in Layer 2 selected, click on the Add Mask icon again to create a new mask. 

6. Select the Marquee tool, draw a rectangle over the Recent Additions / Search area of the EPA image. 
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7. Select the Paint Bucket tool and fill the rectangle you just drew: 

 

8. Export to your H:\ drive; name the file “EPAsearch” and Save. 

9. Delete that mask and create a new one over the right-side content: 

 

10. Export and save as “EPAright”. 



ENGL 323: Writing for New Media Spring 2008 11 of 13 

Dr. Michael Little michaellittle@kings.edu Hafey-Marian 418 

11. Delete that mask and create a new one of the main content: 

 

12. Export and save as “EPAmain”. 

Create the Rollover Javascript 
1. In Dreamweaver, put the cursor inside the table cell to the left of the caption for the EPA image. 

2. Go to Insert > Image and navigate to your assets folder; select “EPA.gif” and click Ok. 

3. Click on the image to select it. 

4. In the Properties panel, at the far left, you’ll see a tiny thumbnail. Just to the right is an empty field; type 
epa in that field. This names the image “epa” within your code and makes it possible to refer to the image 
in code and script. 

 

5. In the caption text, select the words “navigation bar”. 

6. Select the Split view so you can see your design and your code at the same time. 

7. Go to Insert > Hyperlink, and in the dialog box that opens, type # in the Link field. Click Ok. 

8. In the code, you should see <a href=”#”>navigation bar</a> highlighted. 

9. Put the cursor right after “#” and type a space, then (do not hit Enter to create a new line): 
onmouseover=“document.epa.src=‘assets/EPAleft.gif’” 

onmouseout=“document.epa.src=‘assets/EPA.gif’” 
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What you’ve done is tell the browser several things: 

• Don’t go anywhere if someone clicks the link (“#”). 

• When the cursor is over the link (onmouseover) look in the document for the element named epa 
and change its source (src) to the image “EPAleft.gif” in the “assets” folder. 

• When the cursor moves away from the link (onmouseout) look in the document for the element 
named epa and change its source (src) to the image “EPA.gif” in the “assets” folder. 

10. Select “Recent Additions and Search” in the caption and make it a dummy link (#). 

11. Find the link in the code and add the javascript: 
onmouseover=“document.epa.src=‘assets/EPAsearch.gif’” 

onmouseout=“document.epa.src=‘assets/EPA.gif’” 

12. Make “main content” a dummy link and add the javascript: 
onmouseover=“document.epa.src=‘assets/EPAmain.gif’” 

onmouseout=“document.epa.src=‘assets/EPA.gif’” 

13. Make “relevant side content” a dummy link and add the javascript: 
onmouseover=“document.epa.src=‘assets/EPAright.gif’” 

onmouseout=“document.epa.src=‘assets/EPA.gif’” 

14. At the end of the caption text, add, “(Move the cursor over the links for highlights.)” 

15. Save the file and preview it. I think it’s annoying to have the image return to its original state when you 
move away from the link. Go back in your code and remove all of the onmouseout options from the 
code. Then make a dummy link out of “Environmental Protection Agency’s Web site” and add: 
onmouseover=“document.epa.src=‘assets/EPA.gif’” 

Preloading Images 
Once your page is online, the first time you rollover a link there will be a delay before the image switches. This 
happens because the browser has to download your image from the server to make the rollover work, and until the 
image is downloaded nothing happens. You can pre-empt this by including some javascript that will make the 
browser preload all of your rollover images and have them ready to go. Find this in your code: 

</style> 

</head> 

and put your cursor after </style>. Hit Enter and type the following: 

<script type=”text/javascript”> 

<!-- 

Preload1=newImage(475,395) 

Preload1.src=”assets/EPAleft.gif” 

Preload2=newImage(475,395) 

Preload2.src=”assets/EPAsearch.gif” 

Preload3=newImage(475,395) 

Preload3.src=”assets/EPAright.gif” 

Preload4=newImage(475,395) 

Preload4.src=”assets/EPAmain.gif” 

//--> 

</script> 
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Understanding the Color Codes; You Can Totally Skip This Section 
The six digits in the color code are in pairs. The first pair tells how much red is in the color; the second pair tells 
how much green; the third pair tells how much blue. So: 

• Black = 00 (zero) red + 00 green + 00 blue 

• White = FF (the highest value) red + FF green + FF blue 

• Red = FF red + 00 green + 00 blue 

• Green = 00 red + FF green + 00 blue 

• Blue = 00 red + 00 green + 00 blue 

The pairs are hexadecimals, not decimals. In decimal numbering (which we use all the time) we only have ten 
digits, 0 – 9. In hexadecimal numbering, we use sixteen digits, 0 – 9, then A – F. The number nine is 9; the 
number 10 is A; the number 12 is C; the number 15 is F. 

In decimal numbering, the far right digit can only represent numbers as high as 9. In hexadecimal numbering, the 
far right digit goes as high as 15. 

In decimal numbering, the “tens” place still uses the digits 0 – 9, but they tell us how many tens we’re working 
with: 99 is (9 x 10) + (9 x 1), or 90 + 9. 

In hexadecimal numbering, the “sixteens” place uses the digits 0 – F and tells us how many sixteens we’re 
working with: 99 is (9 x 16) + (9 x 1), or 144 + 9, or 153. The highest number in these codes is FF; since F is the 
same as 15, FF = (15 x 16) + (15 x 1), or 240 + 15, or 255. 

You’ll notice if you roam around the color palette that each pair in the color code is limited to 00, 33, 66, 99, CC, 
and FF. For all kinds of complex reasons, these are the “web-safe” colors that any computer will render. The color 
#FFFF00 is yellow and is web-safe—all monitors should present exactly this yellow. You can enter any 
hexadecimal numbers you’d like and create all kinds of colors, but there is a slight risk that some monitors won’t 
show them properly. 


